Categories
Popular posts

Ian Beer publishes details of kernel vulnerability for iOS 14.1 and lower

Ian Beer is a name much of the jailbreak community will recognize, and that’s because he’s a talented security researcher who discovered and published a plethora of different tfp0 exploits over the years — many of which went on to further jailbreak tool development.

Although Beer has been somewhat quiet these past several months, it seems it was for a good reason, as the hacker took to Twitter Thursday afternoon after publishing details for what appears to be a kernel vulnerability impacting iOS & iPadOS 14.1 and below.

The details concerning the new vulnerability are now officially published on the Project Zero blog, and citing Apple’s security content posting for iOS & iPadOS 14.2, the vulnerability enables an application to execute arbitrary code with elevated kernel privileges.

At this time, Beer’s work is only a vulnerability and not an exploit, but it could potentially result in an exploit, and that’s what makes this significant. This means that it could also potentially lead to a jailbreak, but this could only happen only after an exploit is created.

Another thing worth noting is that the exploit doesn’t work out of the box with PAC-equipped devices such as the iPhone XS and newer, which means it would be limited to the iPhone X and older without a PAC bypass mechanism. For what it’s worth, the checkra1n tool can already jailbreak an iPhone X or earlier running iOS 14.1 or below.

Regardless of the caveats, it’s good to finally see some progress in the iOS & iPadOS 14 space, as much of the focus lately has been on iOS & iPadOS 13 instead of Apple’s latest and greatest mobile operating system. This could indicate good things to come in the near future, but this is merely speculation.

Are you excited to see what becomes of Beer’s new kernel vulnerability? Let us know down in the comments section below.

Leave a Reply

Your email address will not be published. Required fields are marked *